CVE-2026-108515
Received Received - Intake

Reflected XSS in Drupal Core

Vulnerability report for CVE-2026-108515, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-10-30

Last updated on: 2026-10-30

Assigner: Drupal.org

Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS). This issue affects Drupal core versions: from 8.9.0 to 10.6.19, from 11.0.0 to 11.3.19, from 11.4.0 to 11.4.10, from 12.0.0-alpha1 to 12.0.0-beta2.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-10-30
Last Modified
2026-10-30
Generated
2026-10-30
AI Q&A
2026-10-30
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 4 associated CPEs
Vendor Product Version / Range
Drupal Drupal core 8.9.0
Drupal Drupal core 11.0.0
Drupal Drupal core 11.4.0
Drupal Drupal core 12.0.0-alpha1

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-79 The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

This is a Cross-site Scripting (XSS) vulnerability in Drupal core. It allows attackers to inject malicious scripts into web pages viewed by other users. The flaw exists due to improper neutralization of user input during web page generation.

Impact Analysis

An attacker could exploit this to steal user sessions, deface websites, or perform actions on behalf of users. It may lead to unauthorized data access, account takeovers, or spreading malware to visitors.

Compliance Impact

This vulnerability could violate GDPR by exposing user data or HIPAA by compromising protected health information. Organizations may face fines or penalties for failing to protect user data adequately.

Mitigation Strategies

Update Drupal core to the latest patched version. For Drupal 8.9.x to 10.6.19, upgrade to 10.6.20 or later. For 11.0.0 to 11.3.19, upgrade to 11.3.20 or later. For 11.4.0 to 11.4.10, upgrade to 11.4.11 or later. For 12.0.0-alpha1 to 12.0.0-beta2, upgrade to a fixed release.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-108515. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart