CVE-2026-115915
Awaiting Analysis Awaiting Analysis - Queue

Remote Code Execution in vLLM via EPS Image Processing

Vulnerability report for CVE-2026-115915, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-10-26

Last updated on: 2026-10-26

Assigner: GitHub, Inc.

Description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-10-26
Last Modified
2026-10-26
Generated
2026-10-26
AI Q&A
2026-10-26
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 1 associated CPE
Vendor Product Version / Range
vllm-project vllm < 0.32.0

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-20 The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
CWE-183 The product implements a protection mechanism that relies on a list of inputs (or properties of inputs) that are explicitly allowed by policy because the inputs are assumed to be safe, but the list is too permissive - that is, it allows an input that is unsafe, leading to resultant weaknesses.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

This vulnerability in vLLM before version 0.32.0 allows attacker-controlled image bytes to be processed by Pillow without restricting decoder selection. This can lead to execution of EPS payloads via Ghostscript (CVE-2024-29510) or trigger CVE-2026-59203 in Pillow versions 12.0.0 to 12.2.0, causing worker exhaustion.

Detection Guidance

Check the installed vLLM version. If it is below 0.32.0, the system is potentially vulnerable. Run: pip show vllm or vllm --version to verify.

Impact Analysis

An attacker could execute arbitrary commands with the privileges of the vLLM process if Ghostscript is vulnerable. Alternatively, they could exhaust system resources by triggering excessive media-loading operations, disrupting service availability.

Mitigation Strategies

Upgrade vLLM to version 0.32.0 or later immediately. If using Pillow 12.0.0 through 12.2.0, update to a non-vulnerable version to prevent CVE-2026-59203.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-115915. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart