CVE-2026-116540
Awaiting Analysis Awaiting Analysis - Queue

Use-After-Free in netty-tcnative with OpenSSL 3.x Session Ticket Keys

Vulnerability report for CVE-2026-116540, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-10-26

Last updated on: 2026-10-26

Assigner: VulnCheck

Description

netty-tcnative 2.0.66.Final before 2.0.84.Final built against OpenSSL 3.x contains a use-after-free vulnerability in ssl_tlsext_ticket_key_cb during session ticket key rotation. Remote clients performing TLS handshakes while setSessionTicketKeys0 frees the shared key array cause OpenSSL to read freed HMAC keys, crashing or corrupting ticket processing.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-10-26
Last Modified
2026-10-26
Generated
2026-10-26
AI Q&A
2026-10-26
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 1 associated CPE
Vendor Product Version / Range
netty netty-tcnative 2.0.66.Final

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-416 The product reuses or references memory after it has been freed. At some point afterward, the memory may be allocated again and saved in another pointer, while the original pointer references a location somewhere within the new allocation. Any operations using the original pointer are no longer valid because the memory "belongs" to the code that operates on the new pointer.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

CVE-2026-116540 is a use-after-free vulnerability in netty-tcnative versions 2.0.66.Final through 2.0.83.Final when built against OpenSSL 3.x. It occurs during session ticket key rotation when a remote client performs a TLS handshake while the shared key array is freed. This causes OpenSSL to read freed HMAC keys, leading to crashes or corruption in ticket processing.

Detection Guidance

To detect this vulnerability, check the version of netty-tcnative in use. Vulnerable versions are 2.0.66.Final through 2.0.83.Final when built against OpenSSL 3.x. Run commands like 'find / -name netty-tcnative*.jar' or check dependency files (pom.xml, build.gradle) for the version. Monitor application logs for crashes during TLS handshakes or session ticket processing.

Impact Analysis

This vulnerability can cause denial-of-service conditions by crashing applications using vulnerable netty-tcnative versions. Attackers can exploit it remotely without privileges or user interaction, triggering instability or memory corruption in systems handling TLS sessions with session tickets enabled.

Mitigation Strategies

Upgrade netty-tcnative to version 2.0.84.Final or later. This version includes fixes for the use-after-free issue in session ticket key handling. If upgrading is not immediately possible, disable session ticket support in your TLS configuration as a temporary workaround.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-116540. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart