CVE-2026-118071
Received Received - Intake

Stored XSS in Joinchat WordPress Plugin

Vulnerability report for CVE-2026-118071, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-10-30

Last updated on: 2026-10-30

Assigner: WPScan

Description

The Joinchat WordPress plugin before 6.4.2 does not escape the message of its button block before outputting it in an HTML attribute on the front end, which could allow users with the Author role and above to perform Stored Cross-Site Scripting attacks against any visitor of the post, including administrators.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-10-30
Last Modified
2026-10-30
Generated
2026-10-30
AI Q&A
2026-10-30
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 1 associated CPE
Vendor Product Version / Range
Unknown Joinchat 6.3.2

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-UNKNOWN

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

This is a Stored Cross-Site Scripting (XSS) vulnerability in the Joinchat WordPress plugin versions 6.3.2 to 6.4.1. It occurs because the plugin does not properly escape the message attribute of its button block before displaying it in an HTML attribute on the front end. This allows users with Author role or higher to inject malicious scripts.

Detection Guidance

Check the installed version of the Joinchat WordPress plugin. If it is between 6.3.2 and 6.4.1, the vulnerability is present. You can verify this via WordPress admin panel under Plugins or by inspecting the plugin files for version details.

Impact Analysis

An attacker with Author role or higher could inject malicious scripts that execute when visitors, including administrators, view the affected post. This could lead to unauthorized actions, data theft, or session hijacking on the website.

Compliance Impact

This vulnerability could lead to data breaches, which may violate GDPR and HIPAA compliance requirements. Unauthorized script execution could expose sensitive user data, resulting in legal penalties and reputational damage.

Mitigation Strategies

Update the Joinchat plugin to version 6.4.2 or later immediately. If updating is not possible, consider disabling the plugin temporarily until an update is applied.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-118071. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart