CVE-2026-119574
Awaiting Analysis Awaiting Analysis - Queue

Traefik FastProxy HTTP/1 Race Condition Denial of Service

Vulnerability report for CVE-2026-119574, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-10-30

Last updated on: 2026-10-30

Assigner: VulnCheck

Description

Traefik from 3.2.0 before 3.7.15 contains a data race in the experimental FastProxy that allows unauthenticated attackers to crash the process by abusing HTTP/1 protocol upgrades. Attackers can repeatedly open and abort upgraded connections such as WebSocket, corrupting the unsynchronized shared bufio.Reader and triggering an unrecovered panic that terminates Traefik.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-10-30
Last Modified
2026-10-30
Generated
2026-10-30
AI Q&A
2026-10-30
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 1 associated CPE
Vendor Product Version / Range
traefik traefik 3.2.0

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-567 The product does not properly synchronize shared data, such as static variables across threads, which can lead to undefined behavior and unpredictable data changes.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

Traefik versions 3.2.0 to 3.7.14 have a data race flaw in the experimental FastProxy feature. This flaw allows unauthenticated attackers to crash the Traefik process by exploiting HTTP/1 protocol upgrades. Attackers repeatedly open and abort upgraded connections like WebSocket, corrupting the shared bufio.Reader due to lack of synchronization. This corruption triggers an unrecovered panic that terminates Traefik entirely.

Detection Guidance

This vulnerability can be detected by checking the Traefik version running on your system. If you are running Traefik version 3.2.0 to 3.7.14, you are vulnerable. Use the command 'traefik version' to check the installed version.

Impact Analysis

If you use Traefik in versions 3.2.0 to 3.7.14, this vulnerability could cause unexpected crashes of your Traefik instances. This may lead to service disruptions, downtime, or loss of availability for applications behind Traefik. Attackers could exploit this to force repeated restarts, degrading performance or making services inaccessible.

Mitigation Strategies

Immediately upgrade Traefik to version 3.7.15 or later to address the data race issue in the experimental FastProxy component.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-119574. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart