CVE-2025-36075
Awaiting Analysis Awaiting Analysis - Queue

IBM Safer Payments Information Disclosure via API

Vulnerability report for CVE-2025-36075, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-11-08

Last updated on: 2026-11-08

Assigner: IBM Corporation

Description

IBM Safer Payments 6.4.0.00 through 6.4.2.11, 6.5.0.00 through 6.5.0.09, 6.6.0.00 through 6.6.0.07, 6.7.0.00 through 6.7.0.03, and 6.8.0.00 could allow an authenticated user to obtain sensitive information, caused by improper user input validation. By using a set of API requests the user could exploit this vulnerability to decrypt sensitive information.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-11-08
Last Modified
2026-11-08
Generated
2026-11-08
AI Q&A
2026-11-08
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 5 associated CPEs
Vendor Product Version / Range
IBM Safer Payments From 6.4.0.0 (inc) to 6.4.2.11 (inc)
IBM Safer Payments From 6.5.0.0 (inc) to 6.5.0.9 (inc)
IBM Safer Payments From 6.6.0.0 (inc) to 6.6.0.7 (inc)
IBM Safer Payments From 6.7.0.0 (inc) to 6.7.0.3 (inc)
IBM Safer Payments 6.8.0.0

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-1287 The product receives input that is expected to be of a certain type, but it does not validate or incorrectly validates that the input is actually of the expected type.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

IBM Safer Payments has a flaw where improper input validation allows authenticated users to access sensitive information. By sending specific API requests, an attacker could decrypt this data. The issue is tracked under CWE-1287 and affects multiple versions of the software.

Detection Guidance

Detection of CVE-2025-36075 requires checking the version of IBM Safer Payments installed on your system. Compare the installed version against the affected versions (6.4.0.00-6.4.2.11, 6.5.0.00-6.5.0.09, 6.6.0.00-6.6.0.07, 6.7.0.00-6.7.0.03, 6.8.0.00). If your version falls within these ranges, the system is vulnerable.

Impact Analysis

If exploited, this vulnerability could lead to unauthorized access to sensitive data, including financial or personal information. Attackers might decrypt confidential details, posing risks to data confidentiality and integrity.

Compliance Impact

This vulnerability could lead to non-compliance with GDPR, HIPAA, or other regulations due to unauthorized data exposure. Organizations may face legal penalties, reputational damage, and loss of trust if sensitive data is compromised.

Mitigation Strategies

Update IBM Safer Payments to version 6.4.2.12, 6.5.0.10, 6.6.0.08, 6.7.0.04, 6.8.0.01, or higher as recommended by IBM to address the vulnerability.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2025-36075. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...