CVE-2026-110535
Received Received - Intake

Improper Privilege Management in Apache Syncope

Vulnerability report for CVE-2026-110535, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-11-02

Last updated on: 2026-11-02

Assigner: Apache Software Foundation

Description

Improper Privilege Management vulnerability in Apache Syncope. AuthProfile self-updates allow non-admin users to configure impersonation for WA surrogate authentication. This issue affects Apache Syncope: from 3.0.12 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0-M0 through 4.1.3. Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-11-02
Last Modified
2026-11-02
Generated
2026-11-02
AI Q&A
2026-11-02
EPSS Evaluated
N/A
NVD

Affected Vendors & Products

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-269 The product does not properly assign, modify, track, or check privileges for an actor, creating an unintended sphere of control for that actor.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

This vulnerability is an Improper Privilege Management issue in Apache Syncope. It allows non-admin users to configure impersonation for WA surrogate authentication through AuthProfile self-updates.

Detection Guidance

This vulnerability allows non-admin users to configure impersonation for WA surrogate authentication due to improper privilege management. Check Apache Syncope logs for unauthorized AuthProfile self-updates or suspicious impersonation attempts. Verify user roles and permissions to ensure only admins can modify authentication settings.

Impact Analysis

Non-admin users could gain unauthorized privileges by exploiting this flaw, potentially allowing them to impersonate other users or escalate their access within the system.

Compliance Impact

This vulnerability could lead to unauthorized access or data breaches, which may violate compliance requirements such as GDPR or HIPAA due to improper privilege management.

Mitigation Strategies

Upgrade Apache Syncope to version 4.0.9 or 4.1.4 or later to address the improper privilege management issue.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-110535. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...