CVE-2026-11376
Undergoing Analysis Undergoing Analysis - In Progress

Integer Overflow in IBM MQ Leading to DoS or Code Execution

Vulnerability report for CVE-2026-11376, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-11-04

Last updated on: 2026-11-04

Assigner: IBM Corporation

Description

IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD could allow an authenticated attacker to cause a denial of service or potentially execute arbitrary code due to an integer overflow when processing subscription requests with crafted buffer size values.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-11-04
Last Modified
2026-11-04
Generated
2026-11-05
AI Q&A
2026-11-04
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 5 associated CPEs
Vendor Product Version / Range
IBM MQ 9.2.0.0
IBM MQ 9.3.0.0
IBM MQ 9.4.0.0
IBM MQ 9.4.0.0
IBM MQ 10.0.0.0

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-190 The product performs a calculation that can produce an integer overflow or wraparound when the logic assumes that the resulting value will always be larger than the original value. This occurs when an integer value is incremented to a value that is too large to store in the associated representation. When this occurs, the value may become a very small or negative number.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

IBM MQ versions 9.2.0.0 through 10.0.0.5 are vulnerable to an integer overflow when processing subscription requests with crafted buffer size values. This flaw allows an authenticated attacker to cause a denial of service or potentially execute arbitrary code due to improper handling of large buffer sizes.

Detection Guidance

Detecting this vulnerability requires checking the installed IBM MQ version against affected ranges. Use commands like 'dspmqver' on IBM MQ systems to verify version details. Monitor network traffic for unusual subscription request patterns that may indicate exploitation attempts.

Impact Analysis

This vulnerability can lead to service disruption by crashing the IBM MQ server or allow attackers to run malicious code on the affected system. Since it requires authentication, attackers must first gain access to the system to exploit it.

Mitigation Strategies

Apply the latest cumulative security updates or upgrades immediately: IBM MQ 9.2.0.46 LTS, 9.3.0.43 LTS, 9.4.0.30 LTS, or upgrade to IBM MQ 10.0.0.6 LTS/CD. No workarounds are available, so patching is critical to prevent potential denial of service or arbitrary code execution.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-11376. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...