CVE-2026-11724
Undergoing Analysis Undergoing Analysis - In Progress

IBM MQ Remote Code Execution via Metadata Validation

Vulnerability report for CVE-2026-11724, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-11-04

Last updated on: 2026-11-04

Assigner: IBM Corporation

Description

IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD could allow an authenticated attacker to execute arbitrary code on a Managed File Transfer agent host due to improper validation of metadata used during script execution.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-11-04
Last Modified
2026-11-04
Generated
2026-11-05
AI Q&A
2026-11-04
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 5 associated CPEs
Vendor Product Version / Range
IBM MQ 9.2.0.0
IBM MQ 9.3.0.0
IBM MQ 9.4.0.0
IBM MQ 9.4.0.0
IBM MQ 10.0.0.0

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-20 The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

CVE-2026-11724 is an arbitrary code execution vulnerability in IBM MQ's Managed File Transfer feature. It occurs due to improper validation of metadata during script execution, allowing an authenticated attacker to run arbitrary code on a Managed File Transfer agent host.

Detection Guidance

Detecting this vulnerability requires checking the installed IBM MQ version and whether the Managed File Transfer feature is enabled. Review system logs for unauthorized script execution attempts or metadata validation failures in IBM MQ environments.

Impact Analysis

This vulnerability could allow attackers to execute malicious code on systems running vulnerable IBM MQ versions, potentially leading to unauthorized access, data breaches, or system compromise. It requires authentication but can have severe consequences if exploited.

Compliance Impact

This vulnerability could lead to unauthorized access or data breaches, which may violate compliance requirements under GDPR, HIPAA, or other regulations. Organizations must address it to maintain data protection and security standards.

Mitigation Strategies

Apply the latest cumulative security updates or upgrades based on your IBM MQ version: 9.2.0.46 for 9.2 LTS, 9.3.0.43 for 9.3 LTS, 9.4.0.30 for 9.4 LTS, or upgrade to 10.0.0.6 for 10.0 LTS. For 9.4 CD and 10.0 CD, upgrade to 10.0.1.0.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-11724. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...