CVE-2026-121424
Awaiting Analysis Awaiting Analysis - Queue

Nodemailer Address Parsing Recipient Redirection Flaw

Vulnerability report for CVE-2026-121424, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-11-03

Last updated on: 2026-11-03

Assigner: VulnCheck

Description

Nodemailer from 3.0.0 before 10.1.4 contains an address parsing vulnerability in addressparser that allows remote attackers to redirect recipients by ending nested RFC 5322 comments at the first closing parenthesis. Attackers can submit addresses whose nested comment hides an attacker address, bypassing conformant validators and recipient allow lists to receive mail or spoof senders in mailparser.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-11-03
Last Modified
2026-11-03
Generated
2026-11-03
AI Q&A
2026-11-03
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 1 associated CPE
Vendor Product Version / Range
nodemailer nodemailer 3.0.0

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-20 The product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

This vulnerability in Nodemailer versions 3.0.0 to 10.1.3 allows attackers to manipulate email recipient addresses by using nested RFC 5322 comments. They hide an attacker-controlled address within these comments, which prematurely ends at the first closing parenthesis. This bypasses standard validators and recipient allow lists, enabling attackers to receive mail intended for others or spoof sender addresses.

Detection Guidance

To detect this vulnerability, check the installed version of Nodemailer in your project. Run 'npm list nodemailer' or check your package.json file. If the version is between 3.0.0 and 10.1.3, the system is vulnerable.

Impact Analysis

If you use a vulnerable Nodemailer version, attackers could intercept emails meant for you by redirecting them to their own addresses. They could also spoof sender addresses, making emails appear to come from trusted sources. This could lead to data breaches, unauthorized access to sensitive information, or phishing attacks.

Compliance Impact

This vulnerability could lead to unauthorized access or disclosure of personal data, violating GDPR's data protection principles and HIPAA's confidentiality requirements. Organizations using vulnerable Nodemailer versions may face compliance violations, legal penalties, and reputational damage due to potential data breaches.

Mitigation Strategies

Immediately update Nodemailer to version 10.1.4 or later. Use 'npm update nodemailer' or manually update the package.json file and reinstall dependencies.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-121424. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...