CVE-2026-123023
Deferred
Deferred - Pending Action
Incorrect Authorization in AgentScope AI Tool via Bash Component
Vulnerability report for CVE-2026-123023, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.
Publication date: 2026-11-05
Last updated on: 2026-11-05
Assigner: VulDB
Description
Description
A flaw has been found in agentscope-ai AgentScope up to 2.0.8. This affects the function check_permissions of the file src/agentscope/tool/_builtin/_bash.py of the component Bash Tool. This manipulation causes incorrect authorization. Remote exploitation of the attack is possible. The exploit has been published and may be used. Upgrading to version 2.0.9 mitigates this issue. Patch name: 6b43b13a46401e86abd3defeed9a8bfe5b37bc6d. It is recommended to upgrade the affected component.
CVSS Scores
EPSS Scores
| Probability: | |
| Percentile: |
Meta Information
Affected Vendors & Products
| Vendor | Product | Version / Range |
|---|---|---|
| agentscope-ai | AgentScope | 2.0.0 |
| agentscope-ai | AgentScope | 2.0.1 |
| agentscope-ai | AgentScope | 2.0.2 |
| agentscope-ai | AgentScope | 2.0.3 |
| agentscope-ai | AgentScope | 2.0.4 |
| agentscope-ai | AgentScope | 2.0.5 |
| agentscope-ai | AgentScope | 2.0.6 |
| agentscope-ai | AgentScope | 2.0.7 |
| agentscope-ai | AgentScope | 2.0.8 |
Helpful Resources
Exploitability
| CWE ID | Description |
|---|---|
| CWE-285 | The product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action. |
| CWE-863 | The product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check. |