CVE-2026-124313
Deferred Deferred - Pending Action

Frappe ERPNext Missing Authorization in Payment Ledger Access

Vulnerability report for CVE-2026-124313, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-11-07

Last updated on: 2026-11-07

Assigner: VulnCheck

Description

Frappe ERPNext before 15.121.4 and 16.x before 16.36.0 contains a missing authorization vulnerability in the whitelisted get_linked_payments_for_doc method. Any authenticated user, including portal users, can supply arbitrary company, doctype, and docname values to read Payment Ledger Entry allocation data for other companies' invoices and vouchers.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-11-07
Last Modified
2026-11-07
Generated
2026-11-07
AI Q&A
2026-11-07
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 2 associated CPEs
Vendor Product Version / Range
frappe erpnext to 15.121.4 (exc)
frappe erpnext From 16.0 (inc) to 16.36.0 (exc)

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-862 The product does not perform an authorization check when an actor attempts to access a resource or perform an action.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

Frappe ERPNext versions before 15.121.4 and 16.x before 16.36.0 have a missing authorization flaw in the whitelisted get_linked_payments_for_doc method. This allows any authenticated user, including portal users, to bypass access controls by providing arbitrary company, doctype, and docname values. As a result, they can read Payment Ledger Entry allocation data belonging to other companies' invoices and vouchers.

Detection Guidance

To detect this vulnerability, check the ERPNext version running on your system. If it is version 15.x before 15.121.4 or 16.x before 16.36.0, it is vulnerable. No specific commands are provided in the context for detection.

Impact Analysis

This vulnerability allows unauthorized users to access sensitive financial data, including payment allocations and ledger entries, across different companies. If exploited, it could lead to data breaches, financial fraud, or unauthorized disclosure of confidential information.

Compliance Impact

This vulnerability likely violates compliance requirements such as GDPR (data protection) and HIPAA (health information privacy) due to unauthorized access to sensitive financial and personal data. It undermines data confidentiality and integrity controls required by these regulations.

Mitigation Strategies

Immediately upgrade ERPNext to version 15.121.4 or later for version 15.x, or to version 16.36.0 or later for version 16.x. Ensure only authorized users have access to sensitive data and review user permissions.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-124313. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...