CVE-2026-124425
Awaiting Analysis Awaiting Analysis - Queue

Parse Server Information Disclosure via Deleted Field Markers

Vulnerability report for CVE-2026-124425, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-11-08

Last updated on: 2026-11-08

Assigner: VulnCheck

Description

Parse Server 8.6.109 before 8.6.116 and 9.10.6-alpha.1 before 9.10.7-alpha.2 contains an information disclosure vulnerability in which create or update responses mark fields as deleted based on stored values the caller cannot read. Attackers with write but not read access to an object can inspect these markers to infer whether protected fields are set.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-11-08
Last Modified
2026-11-08
Generated
2026-11-08
AI Q&A
2026-11-08
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 2 associated CPEs
Vendor Product Version / Range
parse_community parse_server From 8.6.109 (inc) to 8.6.116 (exc)
parse_community parse_server From 9.10.6-alpha.1 (inc) to 9.10.7-alpha.2 (exc)

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-203 The product behaves differently or sends different responses under different circumstances in a way that is observable to an unauthorized actor.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

CVE-2026-124425 is an information disclosure vulnerability in Parse Server versions 8.6.109 to 8.6.115 and 9.10.6-alpha.1 to 9.10.7-alpha.1. It allows attackers with write but not read access to infer whether protected fields are set by inspecting markers in create or update responses that indicate deleted fields based on stored values they cannot read.

Detection Guidance

Check if your parse-server version is within the vulnerable range (>= 8.6.109 and < 8.6.116 or >= 9.10.6-alpha.1 and < 9.10.7-alpha.2). Use commands like 'npm list parse-server' or 'npm view parse-server version' to verify the installed version.

Impact Analysis

This vulnerability could allow unauthorized users with write access to infer sensitive information about protected fields in objects they cannot read. While the impact is limited due to low severity, it may lead to unintended data exposure if attackers can deduce the presence of sensitive fields.

Compliance Impact

This vulnerability could potentially impact compliance with GDPR and HIPAA by enabling unauthorized information disclosure. Attackers with write but not read access can infer the presence of protected fields, which may include sensitive personal or health data. This information leakage violates principles of least privilege and data confidentiality required by these regulations.

Mitigation Strategies
  • Upgrade parse-server to version 8.6.116 or later, or 9.10.7-alpha.2 or later to patch the vulnerability.
  • Avoid granting write access to objects or classes that clients cannot read to prevent information leakage.
  • Perform writes via Cloud Code using the master key and only return client-accessible values.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-124425. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...