CVE-2026-13284
Undergoing Analysis Undergoing Analysis - In Progress

XXE Vulnerability in IBM MQ Software

Vulnerability report for CVE-2026-13284, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-11-04

Last updated on: 2026-11-04

Assigner: IBM Corporation

Description

IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD is vulnerable to an XML external entity injection (XXE) attack when processing XML data. A remote attacker could exploit this vulnerability to expose sensitive information or consume memory resources.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-11-04
Last Modified
2026-11-04
Generated
2026-11-05
AI Q&A
2026-11-05
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 5 associated CPEs
Vendor Product Version / Range
IBM MQ 9.2.0.0
IBM MQ 9.3.0.0
IBM MQ 9.4.0.0
IBM MQ 9.4.0.0
IBM MQ 10.0.0.0

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-611 The product processes an XML document that can contain XML entities with URIs that resolve to documents outside of the intended sphere of control, causing the product to embed incorrect documents into its output.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

CVE-2026-13284 is an XML external entity injection (XXE) vulnerability in IBM MQ versions 9.2.0.0 through 10.0.0.5. It allows a remote attacker to expose sensitive information or consume memory resources by exploiting improper XML external entity references.

Impact Analysis

This vulnerability can lead to unauthorized exposure of sensitive data or denial-of-service conditions due to excessive memory consumption. Attackers could exploit it to access confidential information or disrupt services.

Mitigation Strategies

Apply the latest cumulative security updates for IBM MQ versions 9.2 LTS (9.2.0.46), 9.3 LTS (9.3.0.43), and 9.4 LTS (9.4.0.30). Upgrade to version 10.0.0.6 for 10.0 LTS or to version 10.0.1.0 for 9.4 CD and 10.0 CD. No workarounds are available.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-13284. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...