CVE-2026-71550
Undergoing Analysis Undergoing Analysis - In Progress

Path Traversal in SuiteCRM Workflow Controller

Vulnerability report for CVE-2026-71550, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-11-05

Last updated on: 2026-11-05

Assigner: GitHub, Inc.

Description

SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. Prior to 7.15.2 and 8.10.2, the workflow controller uses a path-traversal-capable aow_action value in require_once() without constraining the resolved file. The affected flow begins at modules/AOW_WorkFlow/controller.php and uses aow_action, and require_once() to carry attacker-controlled data or authorization state into the security-sensitive operation. An authenticated user with the WorkFlow role can include executable PHP, obtain server-side code execution, access CRM data and configuration secrets, and establish persistent access. This issue is fixed in versions 7.15.2 and 8.10.2.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-11-05
Last Modified
2026-11-05
Generated
2026-11-06
AI Q&A
2026-11-05
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 2 associated CPEs
Vendor Product Version / Range
SuiteCRM SuiteCRM < 7.15.2
SuiteCRM SuiteCRM >= 8.0.0, < 8.10.2

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-98 The PHP application receives input from an upstream component, but it does not restrict or incorrectly restricts the input before its usage in "require," "include," or similar functions.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

CVE-2026-71550 is a critical Local File Inclusion (LFI) vulnerability in SuiteCRM affecting versions 7.15.1 and earlier, as well as 8.10.1 and earlier. The flaw exists in the AOW_WorkFlow module's controller.php file, where an authenticated user with the WorkFlow role can exploit path traversal sequences in the 'aow_action' parameter to include and execute arbitrary PHP files on the server via require_once(), leading to Remote Code Execution (RCE).

Detection Guidance

Check SuiteCRM version with: grep -r "version" config.php or check the footer of the SuiteCRM web interface. If version is 7.15.1 or earlier, or 8.10.1 or earlier, the system is vulnerable. Inspect modules/AOW_WorkFlow/controller.php for the vulnerable require_once() call around lines 542–546.

Impact Analysis

An attacker can access and exfiltrate all CRM data, including sensitive records and personally identifiable information (PII). They can retrieve database credentials and other secrets from config.php, read or write to any filesystem location accessible by the web server user, and execute arbitrary system commands. Attackers can also establish persistent access by deploying webshells for long-term compromise.

Compliance Impact

This vulnerability could lead to unauthorized access and exposure of sensitive data, violating GDPR's data protection principles and HIPAA's security and privacy requirements. Non-compliance may result in legal penalties, reputational damage, and loss of trust from customers and regulators.

Mitigation Strategies

Upgrade SuiteCRM to version 7.15.2 or 8.10.2 immediately. Remove or restrict access for users with the WorkFlow role until patched. Monitor for suspicious file inclusions or unauthorized PHP execution in web server logs.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-71550. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...