CVE-2026-73098
Received Received - Intake

Improper Class Loading in Apache Juneau

Vulnerability report for CVE-2026-73098, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-11-05

Last updated on: 2026-11-05

Assigner: Apache Software Foundation

Description

Improper control of dynamically-loaded code vulnerability in Apache Juneau. When Apache Juneau parses a value into a property of type java.lang.Class (including parameterized forms), the default class swap loaded the named class with initialization enabled, so input naming a class on the application classpath ran that class's static initializer. The impact depends on the classes present in the deployment. This issue affects Apache Juneau: through 9.2.0. Users are recommended to upgrade to version 9.2.1, which fixes the issue.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-11-05
Last Modified
2026-11-05
Generated
2026-11-05
AI Q&A
2026-11-05
EPSS Evaluated
N/A
NVD
EUVD

Affected Vendors & Products

Showing 1 associated CPE
Vendor Product Version / Range
Apache Software Foundation Apache Juneau 0

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-470 The product uses external input with reflection to select which classes or code to use, but it does not sufficiently prevent the input from selecting improper classes or code.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

This vulnerability in Apache Juneau involves improper control of dynamically-loaded code. When parsing a value into a property of type java.lang.Class, the default class swap loads the named class with initialization enabled. This means an attacker could input a class name from the application classpath, causing that class's static initializer to run, potentially executing malicious code.

Detection Guidance

This vulnerability involves improper class loading in Apache Juneau versions through 9.2.0. Detection requires checking the installed version of Apache Juneau and verifying if any classes with static initializers are loaded from untrusted input. No specific commands are provided in the context to directly detect this issue.

Impact Analysis

The impact depends on the classes present in the deployment. An attacker could exploit this to execute arbitrary code on the affected system, leading to unauthorized access, data breaches, or system compromise. The CVSS score of 10.0 indicates a critical severity with high impact on confidentiality, integrity, and availability.

Compliance Impact

This vulnerability could lead to data breaches or unauthorized access, violating GDPR's data protection requirements and HIPAA's security and privacy rules. Non-compliance may result in legal penalties, fines, or reputational damage for organizations handling sensitive data.

Mitigation Strategies

Upgrade Apache Juneau to version 9.2.1 or later to fix the vulnerability. Check your deployment for classes that could be exploited via static initializers and remove or restrict access to them.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-73098. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...