CVE-2024-27282
Deferred Deferred - Pending Action

BaseFortify

Vulnerability report for CVE-2024-27282, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2024-05-14

Last updated on: 2026-06-17

Assigner: MITRE

Description

An issue was discovered in Ruby 3.x through 3.3.0. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings. The fixed versions are 3.0.7, 3.1.5, 3.2.4, and 3.3.1.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2024-05-14
Last Modified
2026-06-17
Generated
2026-11-02
AI Q&A
2024-11-02
EPSS Evaluated
2026-10-31
NVD

Affected Vendors & Products

Showing 1 associated CPE
Vendor Product Version / Range
n/a n/a n/a

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-125 The product reads data past the end, or before the beginning, of the intended buffer.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

This vulnerability, identified as CVE-2024-27282, affects certain versions of Ruby (3.x through 3.3.0). It allows an attacker to provide harmful data to the Ruby regex compiler, which can lead to the extraction of sensitive information from the computer's memory. This includes potentially revealing private data and pointers that could be exploited.

Impact Analysis

If you use a vulnerable version of Ruby, an attacker could exploit this vulnerability to access sensitive information from your system. This could lead to data breaches, loss of privacy, and potential misuse of your data.

Compliance Impact

This vulnerability could impact compliance with regulations like GDPR and HIPAA because it may allow unauthorized access to sensitive personal data. If such data is exposed due to this vulnerability, it could lead to violations of these regulations, resulting in legal consequences and fines.

Mitigation Strategies

To mitigate this vulnerability, you should update your Ruby version to one of the fixed versions: 3.0.7, 3.1.5, 3.2.4, or 3.3.1.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2024-27282. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...