CVE-2026-110264
Modified Modified - Updated After Analysis

Integer Overflow in GitLab CE/EE Leading to Arbitrary Code Execution

Vulnerability report for CVE-2026-110264, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-10-22

Last updated on: 2026-10-31

Assigner: GitLab Inc.

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 7.0 before 18.11.13, 19.0 before 19.0.10, 19.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server due to integer overflow when compiling a specially crafted regular expression.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-10-22
Last Modified
2026-10-31
Generated
2026-11-01
AI Q&A
2026-10-22
EPSS Evaluated
2026-10-31
NVD
EUVD

Affected Vendors & Products

Showing 14 associated CPEs
Vendor Product Version / Range
gitlab gitlab From 19.4.0 (inc) to 19.4.3 (exc)
gitlab gitlab From 19.4.0 (inc) to 19.4.3 (exc)
gitlab gitlab 19.5.0
gitlab gitlab 19.5.0
gitlab gitlab From 19.0.0 (inc) to 19.0.10 (exc)
gitlab gitlab From 19.1.0 (inc) to 19.1.9 (exc)
gitlab gitlab From 19.2.0 (inc) to 19.2.9 (exc)
gitlab gitlab From 19.3.0 (inc) to 19.3.6 (exc)
gitlab gitlab From 7.0.0 (inc) to 18.11.13 (exc)
gitlab gitlab From 19.0.0 (inc) to 19.0.10 (exc)
gitlab gitlab From 19.1.0 (inc) to 19.1.9 (exc)
gitlab gitlab From 19.2.0 (inc) to 19.2.9 (exc)
gitlab gitlab From 19.3.0 (inc) to 19.3.6 (exc)
gitlab gitlab From 7.0.0 (inc) to 18.11.13 (exc)

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-190 The product performs a calculation that can produce an integer overflow or wraparound when the logic assumes that the resulting value will always be larger than the original value. This occurs when an integer value is incremented to a value that is too large to store in the associated representation. When this occurs, the value may become a very small or negative number.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

This vulnerability affects GitLab CE/EE versions from 7.0 up to specific patched versions. It allows an unauthenticated user to execute arbitrary code on the GitLab server due to an integer overflow when compiling a specially crafted regular expression.

Detection Guidance

This vulnerability is specific to GitLab versions before 18.11.13, 19.0.10, 19.0.1 before 19.1.9, 19.2 before 19.2.9, 19.3 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1. Check your GitLab version using commands like 'gitlab-rake gitlab:env:info' or 'cat /opt/gitlab/embedded/service/gitlab-rake/version'. If your version is affected, update immediately.

Impact Analysis

An attacker could exploit this to gain full control of the GitLab server, potentially accessing sensitive data, modifying repositories, or disrupting services. The high CVSS score indicates severe impact on confidentiality, integrity, and availability.

Compliance Impact

This vulnerability could lead to unauthorized access to personal or sensitive data, violating GDPR and HIPAA requirements for data protection and access controls. Organizations must patch immediately to maintain compliance.

Mitigation Strategies

Upgrade GitLab to a patched version (18.11.13, 19.0.10, 19.1.9, 19.2.9, 19.3.6, 19.4.3, or 19.5.1 or later) immediately to address the integer overflow issue in regular expression compilation.

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-110264. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...