CVE-2026-111497
Modified Modified - Updated After Analysis

Buffer Overflow in Google Brotli Decoder

Vulnerability report for CVE-2026-111497, including description, CVSS score, EPSS score, affected products, exploitability, helpful resources, and attack-flow context.

Publication date: 2026-10-22

Last updated on: 2026-10-30

Assigner: Google Inc.

Description

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

CVSS Scores

EPSS Scores

Probability:
Percentile:

Meta Information

Published
2026-10-22
Last Modified
2026-10-30
Generated
2026-11-03
AI Q&A
2026-10-23
EPSS Evaluated
2026-11-01
NVD

Helpful Resources

Exploitability

CWE
CWE Icon
KEV
KEV Icon
CWE ID Description
CWE-787 The product writes data past the end, or before the beginning, of the intended buffer.
CWE-252 The product does not check the return value from a method or function, which can prevent it from detecting unexpected states and conditions.

Attack-Flow Graph

AI Quick Actions

Instant insights powered by AI
Executive Summary

This is a buffer overflow vulnerability in the Brotli decoder affecting versions 1.0.3 through 1.2.0. A remote unauthenticated attacker can exploit it by sending a specially crafted Brotli-compressed stream to corrupt adjacent memory, disclose sensitive data, cause denial of service, or potentially execute arbitrary code.

Detection Guidance

To detect this vulnerability, check the installed version of Brotli or Node.js. For Node.js, run: node -v and compare it against patched versions (22.23.4, 24.22.1, 26.12.1). For Brotli, check library versions with pkg-config --modversion libbrotli or similar commands depending on your system.

Impact Analysis

The impact includes potential data breaches from memory disclosure, system crashes from denial of service, or remote code execution allowing full system compromise. Users relying on vulnerable Brotli versions in applications or libraries are at risk if they process untrusted compressed data.

Compliance Impact

This vulnerability could lead to unauthorized memory disclosure or remote code execution, which may result in exposure of sensitive data. For GDPR, this could violate principles of data protection and confidentiality. For HIPAA, it may compromise protected health information if exploited.

Mitigation Strategies

Update all Brotli libraries or binaries from versions 1.0.3 through 1.2.0 to the latest available version (1.0.10, 1.1.1, or 1.2.1).

Chat Assistant

Ask questions about this CVE
Hi! I’m here to help you understand CVE-2026-111497. Ask me anything about the vulnerability, its impact, or mitigation strategies.
0/70

EPSS Chart

Security Radar

News mentioning this vulnerability
Loading related security news...